ALTQ(4) MidnightBSD Kernel Interfaces Manual ALTQ(4)
ALTQ — alternate queuing of network packets
The ALTQ framework provides several disciplines for queuing outgoing network packets. This is done by modifications to the interface packet queues. See altq(9) for details.
The user interface for ALTQ is implemented by the pfctl(8) utility, so please refer to the pfctl(8) and the pf.conf(5) manpages for a complete description of the ALTQ capabilities and how to use it.
The following options in the kernel configuration file are related to ALTQ operation:
Build the ‘‘Class Based Queuing’’ discipline.
Build the ‘‘Random Early Detection’’ extension.
Build ‘‘Random Early Drop’’ for input and output.
Build the ‘‘Hierarchical Packet Scheduler’’ discipline.
Build the traffic conditioner. This option is meaningless at the moment as the conditioner is not used by any of the available disciplines or consumers.
Build the ‘‘Priority Queuing’’ discipline.
Required for SMP builds.
Enable additional debugging facilities.
Note that ALTQ-disciplines cannot be loaded as kernel modules. In order to use a certain discipline you have to build it into a custom kernel. The pf(4) interface, that is required for the configuration process of ALTQ can be loaded as a module.
The driver modifications described in altq(9) are required to use a certain network card with ALTQ. They have been applied to the following hardware drivers: an(4), ath(4), awi(4), bfe(4), bge(4), dc(4), de(4), ed(4), em(4), fxp(4), hme(4), lnc(4), re(4), rl(4), sf(4), sis(4), sk(4), ste(4), vr(4), wi(4), and xl(4).
The ndis(4) framework also has support for ALTQ and thus all encapsulated drivers.
The tun(4) and ng_iface(4) pseudo drivers also do support ALTQ.
pf(4), pf.conf(5), ipfw(8), pfctl(8), altq(9)
MidnightBSD 0.3 October 10, 2005 MidnightBSD 0.3