SMP(4) MidnightBSD Kernel Interfaces Manual SMP(4)
SMP — description of the MidnightBSD Symmetric Multi-Processor kernel
The SMP kernel implements symmetric multi-processor support.
Support for multi-processor systems is present for all Tier-1 architectures on MidnightBSD. Currently, this includes amd64, i386, and sparc64. Support is enabled using options SMP. It is permissible to use the SMP kernel configuration on non-SMP equipped motherboards.
For i386 systems, the SMP kernel supports motherboards that follow the Intel MP specification, version 1.4. In addition to options SMP, i386 also requires device apic. The mptable(1) command may be used to view the status of multi-processor support.
The number of CPUs detected by the system is available in the read-only sysctl variable hw.ncpu.
FreeBSD allows specific CPUs on a multi-processor system to be disabled. The sysctl variable machdep.hlt_cpus is an integer bitmask denoting CPUs to halt, counting from 0. Setting a bit to 1 will result in the corresponding CPU being disabled.
FreeBSD supports hyperthreading on Intel CPU’s on the i386 platform. Since using logical CPUs can cause performance penalties under certain loads, the logical CPUs can be disabled by setting the machdep.hlt_logical_cpus sysctl to one. There are also security implications to running hyperthreading; it is possible to access shared information in the CPU cache although not easy to exploit.
mptable(1), sysctl(8), condvar(9), msleep(9), mtx_pool(9), mutex(9), sema(9), sx(9)
The SMP kernel’s early history is not (properly) recorded. It was developed in a separate CVS branch until April 26, 1997, at which point it was merged into 3.0-current. By this date 3.0-current had already been merged with Lite2 kernel code.
FreeBSD 5.0 introduced support for a host of new synchronization primitives, and a move towards fine-grained kernel locking rather than reliance on a Giant kernel lock. The SMPng Project relied heavily on the support of BSDi, who provided reference source code from the fine-grained SMP implementation found in BSD/OS.
FreeBSD 5.0 also introduced support for SMP on the alpha, ia64, and sparc64 architectures. MidnightBSD 0.2 removed support for the alpha.
Steve Passe 〈fsmp@FreeBSD.org〉
MidnightBSD 0.3 April 28, 2008 MidnightBSD 0.3