AAC(4) MidnightBSD Kernel Interfaces Manual AAC(4)
aac — Adaptec AdvancedRAID Controller driver
The aac driver provides support for the Adaptec AAC family of SCSI Ultra2, Ultra160, and Ultra320, and SATA RAID controllers.
Access to RAID containers is available via the /dev/aacd? device nodes. The aacp device enables the SCSI pass-thru interface and allows devices connected to the card such as CD-ROMs to be available via the CAM scsi(4) subsystem. Note that not all cards allow this interface to be enabled.
The /dev/aac? device nodes provide access to the management interface of the controller. One node exists per installed card. The aliases /dev/afa? and /dev/hpn? exist for compatibilty with the Dell and HP versions of management tools, respectively. If the kernel is compiled with the COMPAT_LINUX option, or the aac_linux.ko and linux.ko modules are loaded, the Linux-compatible ioctl(2) interface for the management device will be enabled and will allow Linux-based management applications to control the card.
The read-only sysctl hw.aac.iosize_max defaults to 65536 and may be set at boot time to another value via loader(8). This value determines the maximum data transfer size allowed to/from an array. Setting it higher will result in better performance, especially for large sequential access patterns. Beware: internal limitations of the card limit this value to 64K for arrays with many members. While it may be safe to raise this value, this is done at the operator’s own risk. Note also that performance peaks at a value of 96K, and drops off dramatically at 128K, due to other limitations of the card.
Controllers supported by the aac driver include:
Adaptec SATA RAID 2410SA
Adaptec SATA RAID 2810SA
Adaptec SATA RAID 21610SA
Adaptec SCSI RAID 2120S
Adaptec SCSI RAID 2130S
Adaptec SCSI RAID 2200S
Adaptec SCSI RAID 2130SLP
Adaptec SCSI RAID 2230SLP
Adaptec SCSI RAID 5400S
Dell CERC SATA RAID 2
Dell PERC 2/Si
Dell PERC 2/QC
Dell PERC 3/Si
Dell PERC 3/Di
Dell PERC 320/DC
HP NetRAID 4M
aac management interface
aac loadable module
Compiling with AAC_DEBUG set to a number between 0 and 3 will enable increasingly verbose debug messages.
The adapter can send status and alert messages asynchronously to the driver. These messages are printed on the system console, and are also queued for retrieval by a management application.
kld(4), linux(4), scsi(4), kldload(8), loader(8), sysctl(8)
The aac driver first appeared in FreeBSD 4.3.
Scott Long 〈scottl@FreeBSD.org〉
This driver is not compatible with Dell controllers that have version 1.x firmware. The firmware version is the same as the kernel version printed in the BIOS POST and driver attach messages.
The controller is not actually paused on suspend/resume.
MidnightBSD 0.3 January 4, 2005 MidnightBSD 0.3