ADDUSER.CONF(5) MidnightBSD File Formats Manual ADDUSER.CONF(5)
adduser.conf — adduser(8) configuration file
The /etc/adduser.conf file is automatically generated by the adduser(8) utility when invoked with the −C command-line option. It is not meant to be edited by hand.
The /etc/adduser.conf file is used to pre-set certain configuration options for the adduser(8) utility. When adduser(8) is invoked, it will check to see if this file exists, and if so, the configuration will be used or offered as the default settings. The adduser.conf file offers three types of configuration:
Default settings offered by adduser(8). These options are specified in the configuration file and offered as the default during every invocation of the adduser(8) utility.
Configuration options which can be set in adduser.conf, but overridden by passing a flag to adduser(8).
Configuration supported by adduser(8) but not offered by a flag or during initial invocation.
In the first case, these options can be set in adduser.conf but will still be offered when adduser(8) is invoked. In the second case, adduser(8) will read the configuration data unless a flag has been passed to override it. For example, the defaultshell option. In the third case, the configuration will be utilized, but the user will never be prompted to modify the default setting by either a flag or an adduser(8) prompt. For example, the upwexpire setting.
The following configuration options can be set in adduser.conf:
The default group new users will be added to.
The default class to place users in as described in login.conf(5).
This option is used to specify what other groups the new account should be added to.
May be one of no, none, random, or yes, as described in adduser(8). As such, the text is not duplicated here and may be read in adduser(8).
The default home directory prefix, usually /home.
The user’s default shell which may be any of the shells listed in shells(5).
Defines the location of the default shell and environment configuration files.
Location of the default new user message file. This message will be sent to all new users if specified here or at the adduser(8) prompt.
The default message enclosed in brackets for the lock account prompt.
The default password expiration time. Format of the date is either a UNIX time in decimal, or a date in dd-mmm-yy[yy] format, where dd is the day, mmm is the month in either numeric or alphabetic format, and yy[yy] is either a two or four digit year. This option also accepts a relative date in the form of n[mhdwoy] where n is a decimal, octal (leading 0) or hexadecimal (leading 0x) digit followed by the number of Minutes, Hours, Days, Weeks, Months or Years from the current date at which the expiration time is to be set.
The default account expire time. The format is similar to the upwexpire option.
The default information to be held in the GECOS field of /etc/master.passwd.
The default user ID setting. This must be a number above 1000 and fewer than 65534.
The following is an example adduser.conf file created with the −C adduser(8) flag and modified.
# Configuration file
# NOTE: only *some* variables are saved.
# Last Modified on Fri Mar 30 14:04:05 EST 2004.
upwexpire=91d # Expire passwords 91 days after creation.
group(5), passwd(5), adduser(8), pw(8), rmuser(8)
The adduser.conf manual page first appeared in FreeBSD 5.3.
The internal variables documented here may change without notice. Do not rely on them. To modify this file invoke adduser(8) with the −C option instead.
This manual page was written by Tom Rhodes 〈trhodes@FreeBSD.org〉.
MidnightBSD 0.3 April 12, 2007 MidnightBSD 0.3