ADW(4) MidnightBSD Kernel Interfaces Manual ADW(4)
adw — Advansys PCI 16bit SCSI Host adapter driver
For one or more SCSI busses:
This driver provides access to the 16bit SCSI bus connected to the Advanced Systems Products, Inc. ASC3550 Ultra, and ASC38C0800 Ultra2, SCSI Host Adapter chips. Both chips support, synchronous transfers (20MHz and 40MHz max respectively), 16bit transfers, tagged queueing, and up to 253 concurrent SCSI transactions.
Per target configuration performed in the AdvanceWare menu, which is accessible at boot, is honored by this driver. This includes synchronous/asynchronous transfers, maximum synchronous negotiation rate, wide transfers, disconnection, tagged queueing, and the host adapter’s SCSI ID. The global setting for the maximum number of tagged transactions allowed per target is not honored as the CAM SCSI system will automatically determine the maximum number of tags a device can receive as well as guarantee fair resource allocation among devices.
The adw driver supports SCSI controllers including:
adv(4), cd(4), da(4), sa(4), scsi(4)
The adw driver appeared in FreeBSD 3.0.
The adw driver was ported by Justin T. Gibbs from the Linux driver written by Bob Frey of Advanced System Products, Inc. Many thanks to AdvanSys for providing the original driver under a suitable license for use in FreeBSD.
MidnightBSD 0.3 July 14, 2004 MidnightBSD 0.3