ARCMSR(4) MidnightBSD Kernel Interfaces Manual ARCMSR(4)
arcmsr — Areca SATA II RAID Controller driver
The arcmsr driver provides support for the Areca ARC-11xx and ARC-12xx series of SATA II RAID controllers. These controllers feature RAID-0, 1, 3, 5, 6, and 10 and JBOD acceleration for up to 16 SATA drives. Raid level and stripe level migration, online capacity expansion, hot insertion/removal, automatic failover and rebuild, and SMART are also supported. Access to the arrays is provided via the SCSI CAM /dev/da? device nodes. A management interface is also present via the /dev/arcmsr? device node. Management tools for i386 and amd64 are available from Areca.
The arcmsr driver supports the following cards:
Array block device
The arcmsr driver first appeared in FreeBSD 5.4.
The driver was written by Erich Chen 〈firstname.lastname@example.org〉.
The driver has been tested on i386 and amd64. It likely requires additional work to function on big-endian architectures.
MidnightBSD 0.3 March 31, 2005 MidnightBSD 0.3