AUDIT_CLASS(5) MidnightBSD File Formats Manual AUDIT_CLASS(5)
audit_class — audit event class descriptions
The audit_class file contains descriptions of the auditable event classes on the system. Each auditable event is a member of an event class. Each line maps an audit event mask (bitmap) to a class and a description. Entries are of the form:
Example entries in this file are:
0x00000004:fa:file attribute access
0xffffffff:all:all flags set
audit(4), audit_control(5), audit_event(5), audit_user(5)
The OpenBSM implementation was created by McAfee Research, the security division of McAfee Inc., under contract to Apple Computer Inc. in 2004. It was subsequently adopted by the TrustedBSD Project as the foundation for the OpenBSM distribution.
This software was created by McAfee Research, the security research division of McAfee, Inc., under contract to Apple Computer Inc. Additional authors include Wayne Salamon, Robert Watson, and SPARTA Inc.
The Basic Security Module (BSM) interface to audit records and audit event stream format were defined by Sun Microsystems.
MidnightBSD 0.3 January 24, 2004 MidnightBSD 0.3