AUDIT_CONTROL(5) MidnightBSD File Formats Manual AUDIT_CONTROL(5)
audit_control — audit system parameters
The audit_control file contains several audit system parameters. Each line of this file is of the form:
The parameters are:
The directory where audit log files are stored. There may be more than one of these entries. Changes to this entry can only be enacted by restarting the audit system. See audit(8) for a description of how to restart the audit system.
Specifies which audit event classes are audited for all users. audit_user(5) describes how to audit events for individual users. See the information below for the format of the audit flags.
Contains the audit flags that define what classes of events are audited when an action cannot be attributed to a specific user.
The minimum free space required on the file system audit logs are being written to. When the free space falls below this limit a warning will be issued. Not currently used as the value of 20 percent is chosen by the kernel.
A list of global audit policy flags specifying various behaviors, such as fail stop, auditing of paths and arguments, etc.
Maximum trail size in bytes; if set to a non-0 value, the audit daemon will rotate the audit trail file at around this size. Sizes less than the minimum trail size (default of 512K) will be rejected as invalid. If 0, trail files will not be automatically rotated based on file size.
Audit flags are a comma-delimited list of audit classes as defined in the audit_class(5) file. Event classes may be preceded by a prefix which changes their interpretation. The following prefixes may be used for each class:
Record both successful and failed events.
Record successful events.
Record failed events.
Record neither successful nor failed events.
Do not record successful events.
Do not record failed events.
AUDIT POLICY FLAGS
The policy flags field is a comma-delimited list of policy flags from the following list:
Allow processes to continue running even though events are not being audited. If not set, processes will be suspended when the audit store space is exhausted. Currently, this is not a recoverable state.
Fail stop the system if unable to audit an event—this consists of first draining pending records to disk, and then halting the operating system.
Audit command line arguments to execve(2).
Audit environmental variable arguments to execve(2).
Include a unique audit sequence number token in generated audit records (not implemented on FreeBSD or Darwin).
Include supplementary groups list in generated audit records (not implemented on FreeBSD or Darwin; supplementary groups are never included in records on these systems).
Append a trailer token to each audit record (not implemented on FreeBSD or Darwin; trailers are always included in records on these systems).
Include secondary file paths in audit records (not implemented on FreeBSD or Darwin; secondary paths are never included in records on these systems).
Include a zone ID token with each audit record (not implemented on FreeBSD or Darwin; FreeBSD audit records do not currently include the jail ID or name).
Enable auditing for each local zone (not implemented on FreeBSD or Darwin; on FreeBSD, audit records are collected from all jails and placed in a single global trail, and only limited audit controls are permitted within a jail).
It is recommended that installations set the cnt flag but not ahlt flag unless it is intended that audit logs exceeding available disk space halt the system.
The following settings appear in the default audit_control file:
The flags parameter above specifies the system-wide mask corresponding to login/logout events. The policy parameter specifies that the system should neither fail stop nor suspend processes when the audit store fills. The trail file will not be automatically rotated by the audit daemon based on file size.
audit(4), audit_class(5), audit_event(5), audit_user(5), audit(8), auditd(8)
The OpenBSM implementation was created by McAfee Research, the security division of McAfee Inc., under contract to Apple Computer Inc. in 2004. It was subsequently adopted by the TrustedBSD Project as the foundation for the OpenBSM distribution.
This software was created by McAfee Research, the security research division of McAfee, Inc., under contract to Apple Computer Inc. Additional authors include Wayne Salamon, Robert Watson, and SPARTA Inc.
The Basic Security Module (BSM) interface to audit records and audit event stream format were defined by Sun Microsystems.
MidnightBSD 0.3 January 4, 2006 MidnightBSD 0.3