CORETEMP(4) MidnightBSD Kernel Interfaces Manual CORETEMP(4)
coretemp — device driver for Intel Core on-die digital thermal sensor
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The coretemp driver provides support for the on-die digital thermal sensor present in Intel Core and newer CPUs.
The coretemp driver reports each core’s temperature through a sysctl node in the corresponding CPU device’s sysctl tree, named dev.cpu.%d.temperature.
The coretemp driver first appeared in FreeBSD 7.0.
The coretemp driver was written by Rui Paulo 〈rpaulo@FreeBSD.org〉 as part of a Google Summer of Code project. This manual page was written by Dag-Erling Smørgrav 〈des@FreeBSD.org〉.
MidnightBSD 0.3 August 23, 2007 MidnightBSD 0.3