DEVFS.RULES(5) MidnightBSD File Formats Manual DEVFS.RULES(5)
devfs.rules — devfs configuration information
The devfs.rules file provides an easy way to create and apply devfs(8) rules, even for devices that are not available at boot.
For devices available at boot, see devfs.conf(5).
The format of this file is simple. Empty lines and lines beginning with a hash sign (‘#’) are ignored. A line between brackets denotes the start of a ruleset. In the brackets should be the name of the ruleset and its number, separated by an equal sign.
Other lines are rule specifications as documented in devfs(8), in the section Rule Specification. These lines are prepended with ‘‘rule’’ and are passed to devfs(8) by the startup scripts of the system. It is important to put path elements that contain glob(3) special characters between quotes.
To make all the partitions of da(4) devices readable and writable by their owner and the ‘‘usb’’ group, the following rule may be used:
add path ’da*s*’ mode 0660 group usb
To make all the uscanner(4) devices accessible to their owner and the ‘‘usb’’ group, a similar rule may be used:
add path ’uscanner*’ mode 0660 group usb
glob(3), devfs(5), devfs.conf(5), devfs(8)
This manual page was written by Roland Smith 〈firstname.lastname@example.org〉.
MidnightBSD 0.3 May 17, 2005 MidnightBSD 0.3