DHCLIENT.LEASES(5) MidnightBSD File Formats Manual DHCLIENT.LEASES(5)
dhclient.leases — DHCP client lease database
The Internet Software Consortium DHCP client keeps a persistent database of leases that it has acquired that are still valid. The database is a free-form ASCII file containing one valid declaration per lease. If more than one declaration appears for a given lease, the last one in the file is used. The file is written as a log, so this is not an unusual occurrence.
The lease file is named dhclient.leases.IFNAME, where IFNAME represents the network interface the DHCP client acquired the lease on. For example, if dhclient(8) is configured for the em0 network device, the lease file will be named dhclient.leases.em0.
The format of the lease declarations is described in dhclient.conf(5).
Current lease file.
dhclient.conf(5), dhcpd.conf(5), dhcp-options(5), dhclient(8), dhcpd(8)
RFC 2132, RFC 2131
The dhclient(8) utility was written by Ted Lemon 〈firstname.lastname@example.org〉 under a contract with Vixie Labs.
The current implementation was reworked by Henning Brauer 〈email@example.com〉.
MidnightBSD 0.3 January 1, 1997 MidnightBSD 0.3