FDESCFS(5) MidnightBSD File Formats Manual FDESCFS(5)
fdescfs — file-descriptor file system
fdescfs rw 0 0
The file-descriptor file system, or fdescfs, provides access to the per-process file descriptor namespace in the global file system namespace. The conventional mount point is /dev/fd.
The file system’s contents appear as a list of numbered files which correspond to the open files of the process reading the directory. The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can be accessed through the file system. If the file descriptor is open and the mode the file is being opened with is a subset of the mode of the existing descriptor, the call:
fd = open("/dev/fd/0", mode);
and the call:
fd = fcntl(0, F_DUPFD, 0);
Flags to the open(2) call other than O_RDONLY, O_WRONLY and O_RDWR are ignored.
The fdescfs file system first appeared in 4.4BSD. The fdescfs manual page first appeared in FreeBSD 2.2.
The fdescfs manual page was written by Mike Pritchard 〈mpp@FreeBSD.org〉, and was based on the mount_fdescfs(8) manual page written by Jan-Simon Pendry.
MidnightBSD 0.3 December 14, 1996 MidnightBSD 0.3