FXP(4) MidnightBSD Kernel Interfaces Manual FXP(4)
fxp — Intel EtherExpress PRO/100 Ethernet device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The fxp driver provides support for Ethernet adapters based on the Intel i82557, i82558, i82559, i82550, and i82562 chips.
The fxp driver supports the following media types:
Enable autoselection of the media type and options
Set 10Mbps operation
Set 100Mbps (Fast Ethernet) operation
The fxp driver supports the following media options:
Set full duplex operation
Note that 100baseTX media type is not available on the Pro/10. For further information on configuring this device, see ifconfig(8).
The fxp driver supports reception and transmission of extended frames for vlan(4). This capability of fxp can be controlled by means of the vlanmtu parameter to ifconfig(8).
The fxp driver also supports a special link option:
Some chip revisions have loadable microcode which can be used to reduce the interrupt load on the host cpu. Not all boards have microcode support. Setting the link0 flag with ifconfig(8) will download the microcode to the chip if it is available.
Adapters supported by the fxp driver include:
Intel EtherExpress PRO/10
Intel InBusiness 10/100
Intel PRO/100B / EtherExpressPRO/100 B PCI Adapter
Intel PRO/100+ Management Adapter
Intel PRO/100 VE Desktop Adapter
Intel PRO/100 VM Network Connection
Intel PRO/100 M Desktop Adapter
Intel PRO/100 S Desktop, Server and Dual-Port Server Adapters
Contec C-NET(PI)-100TX (PC-98)
NEC PC-9821Ra20, Rv20, Xv13, Xv20 internal 100Base-TX (PC-98)
NEC PC-9821X-B06 (PC-98)
Many on-board network interfaces on Intel motherboards
fxp%d: couldn’t map memory A fatal initialization error has occurred.
fxp%d: couldn’t map interrupt A fatal initialization error has occurred.
fxp%d: Failed to malloc memory There are not enough mbuf’s available for allocation.
fxp%d: device timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
fxp%d: Microcode loaded, int_delay: %d usec bundle_max: %d The chip has successfully downloaded the microcode, and changed the parameterized values to the given settings.
altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
The fxp device driver first appeared in FreeBSD 2.1.
The fxp device driver was written by David Greenman. It has then been updated to use the busdma API and made endian-clean by Maxime Henrion. This manual page was written by David E. O’Brien.
MidnightBSD 0.3 January 7, 2007 MidnightBSD 0.3