HFA(4) MidnightBSD Kernel Interfaces Manual HFA(4)
hfa — FORE Systems 200-Series ATM adapter driver
The hfa driver provides support for the FORE Systems ATM series 200 adapters. This driver will support up to eight devices in a system at any given time. The hfa driver follows the AALI or FORE ATM Adaptation Layer Interface and as such will adhere to its specifications. The supported AALs include:
FORE AAL 0: The cell service;
FORE AAL 4: Version three and four of AAL;
FORE AAL 5: Version five of AAL.
The hfa driver supports traffic shaping for cards with firmware revisions of 4.X.X, see fore_dnld(8). The following sysctls are recognized by the driver and may be used to enable or disable traffic shaping:
Disable shaping on card number N.
Set one VCI to be traffic shaped on device N. This will shape the first CBR VCI which is opened.
Attempt to shape all VCIs on device N.
The firmware should be loaded before using this driver, this can be an easy task if the fore_dnld(8) utility is used. If the /etc/rc.d/atm1 file has been properly configured then the firmware update should be automatic.
The hfa driver supports the following adapters:
FORE Systems PCA-200E ATM
FORE Systems 200S
FORE Systems 200
fore_cmd_drain: %s%d: GET_PROM failed The driver failed to drain the PROM buffer.
fore initialization failed: intf=%s%d Initialization of the card has failed.
fore initialization timed out: intf=%s%d Initialization of the card has timed out.
hfa: version mismatch: fore=%d.%d kernel=%d.%d A version mismatch error has occurred.
fatm(4), harp(4), ng_atm(4), atm(8), fore_dnld(8)
The hfa driver was written by Network Computing Services, Inc. and added to FreeBSD 3.0 by Poul-Henning Kamp 〈phk@FreeBSD.org〉. This manual page first appeared in FreeBSD 5.3.
This manual page was written by Tom Rhodes 〈trhodes@FreeBSD.org〉.
MidnightBSD 0.3 August 6, 2004 MidnightBSD 0.3