I4BIPR(4) MidnightBSD Kernel Interfaces Manual I4BIPR(4)
i4bipr — isdn4bsd IP over ISDN B-channel network driver
device "i4bipr" [count]
The i4bipr driver interfaces the IP subsystem of the operating system with the isdn4bsd package so that transport of IP packets over an ISDN link is possible.
The driver just packs IP packets without anything appended or prepended into raw HDLC packets on the B channel and transfers them to a remote site. IP packets received from the remote site are queued into the local IP protocol stack.
The format of the resulting packet on the B channel is:
(HDLC opening flag) (IP-packet) (CRC) (HDLC closing flag)
In the case where an IP packet for a remote site arrives in the driver and no connection has been established yet, the driver communicates with the isdnd(8) daemon to establish a connection.
The driver has support for interfacing to the bpf(4) subsystem for using tcpdump(1) with the ipr interfaces.
The driver optionally (when compiled with the IPR_VJ option) provides Van Jacobsen header compression, under control of the link0 and link1 options to ifconfig(8):
Apply VJ compression to outgoing packets on this interface, and assume that incoming packets require decompression.
Check incoming packets for Van Jacobsen compression; if they appear to be compressed, automatically set link0.
The default values are on for link1 and off for link0.
tcpdump(1), bpf(4), isdnd.rc(5), isdnd(8)
The i4bipr device driver and this manpage were written by Hellmuth Michaelis 〈hm@FreeBSD.org〉.
MidnightBSD 0.3 July 28, 2002 MidnightBSD 0.3