I4BISPPP(4) MidnightBSD Kernel Interfaces Manual I4BISPPP(4)
i4bisppp — isdn4bsd synchronous PPP over ISDN B-channel network driver
device "i4bisppp" [count]
The i4bisppp driver interfaces the IP subsystem of the operating system with the isdn4bsd package so that a transport of IP packets over an ISDN link is possible.
The driver is just a glue layer between the sppp(4) backend and the ISDN4BSD package and needs the sppp(4) driver configured into the kernel.
The network interfaces provided by this driver are named isp<n>, where <n> is a number between 0 and count-1 from the kernel config line.
For configuration of the i4bsppp driver, either the spppcontrol(8) utility is used or the driver can be configured via isdnd(8) and its associated isdnd.rc(5) file.
In case an IP packet for a remote side arrives in the driver and no connection is established yet, the driver communicates with the isdnd(8) daemon to establish a connection.
The driver has support for interfacing to the bpf(4) subsystem for using tcpdump(1) with the isp interfaces.
LINK0 and LINK1
The link0 and link1 flags given as parameters to ifconfig(8) have the following meaning for the isp<n> devices:
wait passively for connection
auto-dial on output
The link0 and link1 flags are set to off by default.
See sppp(4) for a more detailed discussion of the flags.
tcpdump(1), bpf(4), sppp(4), isdnd.rc(5), isdnd(8), spppcontrol(8)
The i4bisppp device driver was written by Joerg Wunsch 〈joerg@FreeBSD.org〉 and then added to ISDN4BSD by Gary Jennejohn 〈gj@FreeBSD.org〉.
This manpage was written by Hellmuth Michaelis 〈hm@FreeBSD.org〉.
MidnightBSD 0.3 July 28, 2002 MidnightBSD 0.3