CNW(4) MidnightBSD Kernel Interfaces Manual CNW(4)
cnw — Netwave AirSurfer wireless network driver
The cnw interface provides access to a theoretical 1Mb/s wireless Ethernet network based on the Netwave AirSurfer Wireless LAN (formerly known as the Xircom Netwave Wireless LAN).
Note that the driver does not support newer devices such as the Netwave AirSurfer ‘‘Plus’’, or the BayStack 650/660. These devices are supported by the awi(4) driver.
Netwave devices are not compatible with IEEE 802.11 wireless networks. Also note that there are Netwave devices with different wireless frequency, depending on the radio band plan in each country.
The card uses 36K of I/O memory mapped to the card. You may need to increase memory space available to the PC Card controller. See pccard(4) for details.
In use, the cards appear to achieve up to a 420Kb/s transfer rate, though a transfer rate between 250Kb/s and 350Kb/s is typical.
The card operates in the 2.4GHz frequency range and is subject to interference from microwaves, IEEE 802.11 wireless network devices, as well as earth. For example, it seems that IEEE 802.11 channel 14 conflicts with Netwave (US frequency). They interfere with each other if they are both operated in the same geographic region, causing weird packet loss. You may be able to avoid the interference with IEEE 802.11 devices, by changing the IEEE 802.11 channel.
Cards supported by the cnw driver include:
Xircom CreditCard Netwave
cnw0: can’t map memory Indicates that the driver was not able to allocate enough PC Card bus address space into which to map the device. See pccard(4) and increase memory available to the PC Card controller.
arp(4), awi(4), inet(4), intro(4), pccard(4)
The cnw driver was ported from NetBSD by Hiroyuki Aizu 〈firstname.lastname@example.org〉. It first appeared in NetBSD 1.4. The first FreeBSD release to include it was FreeBSD 5.0. This manual page was adopted from NetBSD by Christian Brueffer 〈brueffer@FreeBSD.org〉.
MidnightBSD 0.3 September 5, 2004 MidnightBSD 0.3