CUE(4) MidnightBSD Kernel Interfaces Manual CUE(4)
cue — CATC USB-EL1210A USB Ethernet driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The cue driver provides support for USB Ethernet adapters based on the Computer Access Technology Corporation’s USB-EL1210A chipset.
The USB-EL1210A supports a 512-bit multicast hash filter, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints.
The CATC chipset supports only 10Mbps half-duplex mode, hence there are no ifmedia(4) modes to select.
For more information on configuring this device, see ifconfig(8).
The cue driver supports CATC USB-EL1210A based USB Ethernet adapters including:
CATC Netmate II
cue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired.
cue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
arp(4), netintro(4), ng_ether(4), ifconfig(8)
The cue device driver first appeared in FreeBSD 4.0.
The cue driver was written by Bill Paul 〈email@example.com〉.
MidnightBSD 0.3 July 16, 2005 MidnightBSD 0.3