DE(4) MidnightBSD Kernel Interfaces Manual DE(4)
de — DEC DC21x4x Ethernet device driver
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The de driver provides support for the Ethernet adapters based on the Digital Equipment DC21x4x based self-contained Ethernet and Fast Ethernet chips.
The de driver supports the following media types:
Enable autoselection of the media type and options
Set 10Mbps operation on the 10baseT port
Set 10Mbps operation on the BNC port
Set 10Mbps operation on the AUI port
Set 100Mbps (Fast Ethernet) operation
Set 100Mbps operation
Set 100Mbps operation (4-pair cat-3 cable)
The de driver supports the following media options:
Set full duplex operation
Note that the media types available depend on the particular card in use. Some cards are explicitly programmed to a particular media type by a setup utility and are not changeable.
Use the ifconfig(8) command an in particular the −m flag to list the supported media types for your particular card.
The old ‘‘ifconfig linkN’’ method of configuration is not supported.
Adapters supported by the de driver include:
Cogent EM100FX and EM440TX
Corega FastEther PCI-TX
DEC DE435, DEC DE450, and DEC DE500
ELECOM LD-PCI2T, LD-PCITS
I-O DATA LA2/T-PCI
SMC Etherpower 8432, 9332 and 9334
de%d: waking device from sleep/snooze mode The 21041 and 21140A chips support suspending the operation of the card.
de%d: error: desired IRQ of %d does not match device’s actual IRQ of %d The device probe detected that the board is configured for a different interrupt than the one specified in the kernel configuration file.
de%d: not configured; limit of %d reached or exceeded There is a limit of 32 de devices allowed in a single machine.
de%d: not configured;
21040 pass 2.0 required (%d.%d found)
de%d: not configured; 21140 pass 1.1 required (%d.%d found) Certain revisions of the chipset are not supported by this driver.
arp(4), netintro(4), ng_ether(4), ifconfig(8)
The de device driver was written by Matt Thomas. This manual page was written by David E. O’Brien.
MidnightBSD 0.3 July 16, 2005 MidnightBSD 0.3