DISC(4) MidnightBSD Kernel Interfaces Manual DISC(4)
disc — software discard network interface
The disc interface is a software discard mechanism which may be used for performance analysis and/or software testing. As with other network interfaces, the discard interface must have network addresses assigned for each address family with which it is to be used. These addresses may be set or changed with the SIOCSIFADDR ioctl(2).
Each disc interface is created at runtime using interface cloning. This is most easily done with the ifconfig(8) create command or using the cloned_interfaces variable in rc.conf(5).
The disc device appears to have been derived from the lo(4) device around the time of 4.4BSD. This manpage was adapted from lo(4) and first appeared in FreeBSD 5.0.
MidnightBSD 0.3 May 25, 2002 MidnightBSD 0.3