MY(4) MidnightBSD Kernel Interfaces Manual MY(4)
my — Myson Technology Ethernet PCI driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The my driver provides support for various NICs based on the Myson chipset. The Myson chipset is a variant of the DEC Tulip NIC chipset.
The driver will work with almost any MII-compliant PHY, thus failure to positively identify the chip is not a fatal error.
The my driver provides support for various NICs based on the Myson chipset. Supported models include:
Myson MTD800 PCI Fast Ethernet chip
Myson MTD803 PCI Fast Ethernet chip
Myson MTD89X PCI Gigabit Ethernet chip
de(4), miibus(4), netintro(4), pci(4), ifconfig(8)
The my driver first appeared in FreeBSD 4.6.
The my driver was written by Myson Technology Inc.
This manual page was written by Hiten M. Pandya 〈hmp@FreeBSD.org〉.
The my driver does not support Power Management Events (PME).
MidnightBSD 0.3 July 16, 2005 MidnightBSD 0.3