RE(4) MidnightBSD Kernel Interfaces Manual RE(4)
re — RealTek 8139C+/8169/8169S/8110S PCI Ethernet adapter driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The re driver provides support for various NICs based on the RealTek RTL8139C+, RTL8169, RTL8169S and RTL8110S PCI Ethernet controllers.
NICs based on the 8139C+ are capable of 10 and 100Mbps speeds over CAT5 cable. NICs based on the 8169, 8169S and 8110S are capable of 10, 100 and 1000Mbps operation.
All NICs supported by the re driver have TCP/IP checksum offload and hardware VLAN tagging/insertion features, and use a descriptor-based DMA mechanism. They are also capable of TCP large send (TCP segmentation offload).
The 8139C+ is a single-chip solution combining both a 10/100 MAC and PHY. The 8169 is a 10/100/1000 MAC only, requiring a GMII or TBI external PHY. The 8169S and 8110S are single-chip devices containing both a 10/100/1000 MAC and 10/100/1000 copper PHY. Standalone 10/100/1000 cards are available in both 32-bit PCI and 64-bit PCI models. The 8110S is designed for embedded LAN-on-motherboard applications.
The 8169, 8169S and 8110S also support jumbo frames, which can be configured via the interface MTU setting. The MTU is limited to 7422, since the chip cannot transmit larger frames. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit jumbo frames.
The re driver supports the following media types:
Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5).
Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
Set 100Mbps (Fast Ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
Set 1000baseTX operation over twisted pair. The RealTek gigE chips support 1000Mbps in full-duplex mode only.
The re driver supports the following media options:
Force full duplex operation.
Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The re driver supports RealTek RTL8139C+, RTL8169, RTL8169S and RTL8110S based Fast Ethernet and Gigabit Ethernet adapters including:
Alloy Computer Products EtherGOLD 1439E 10/100 (8139C+)
Compaq Evo N1015v Integrated Ethernet (8139C+)
Corega CG-LAPCIGT Gigabit Ethernet (8169S)
D-Link DGE-528(T) Gigabit Ethernet (8169S)
Gigabyte 7N400 Pro2 Integrated Gigabit Ethernet (8110S)
LevelOne GNC-0105T (8169S)
PLANEX COMMUNICATIONS Inc. GN-1200TC (8169S)
Xterasys XN-152 10/100/1000 NIC (8169)
re%d: couldn’t map memory A fatal initialization error has occurred.
re%d: couldn’t map ports A fatal initialization error has occurred.
re%d: couldn’t map interrupt A fatal initialization error has occurred.
re%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization.
re%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot.
re%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization.
re%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
RealTek Semiconductor RTL8139C+, RTL8169, RTL8169S and RTL8110S datasheets
The re device driver first appeared in FreeBSD 5.2.
The re driver was written by Bill Paul 〈email@example.com〉.
The Xterasys XN-152 32-bit PCI NIC, which uses the RTL8169 MAC and Marvell 88E1000 PHY, has a defect that causes DMA corruption if the board is plugged into a 64-bit PCI slot. The defect lies in the board design, not the chip itself: the PCI REQ64# and ACK64# lines should be pulled high, but they are not. The result is that the 8169 chip is tricked into performing 64-bit DMA transfers even though a 64-bit data path between the NIC and the bus does not actually exist.
Unfortunately, it is not possible to correct this problem in software, however it is possible to detect it. When the re driver is loaded, it will run a diagnostic routine designed to validate DMA operation by placing the chip in digital loopback mode and initiating a packet transmission. If the card functions properly, the transmitted data will be echoed back unmodified. If the echoed data is corrupt, the driver will print an error message on the console and abort the device attach. The user should insure the NIC is installed in a 32-bit PCI slot to avoid this problem.
The RealTek 8169, 8169S and 8110S chips appear to only be capable of transmitting jumbo frames up to 7.5K in size.
MidnightBSD 0.3 July 16, 2004 MidnightBSD 0.3