ISDND.RATES(5) MidnightBSD File Formats Manual ISDND.RATES(5)
isdnd.rates — isdn4bsd ISDN management daemon rates description file
The file isdnd.rates contains descriptions how long charging units last at a given time of day, day of week and the distance to the destination. If this file is available, this information may be used by the isdnd(8) ISDN connection management daemon to calculate the short hold time for a connection.
The format of a rate entry line is as follows:
The first field, the (rate-code) defines a collection of rates (for each day of the week) which can be referenced in the isdnd(8) configuration file isdnd.rc(5). This field must start with the identifier ‘‘ra’’ followed by a digit in the range of zero to four.
The second field, the (day-number) selects the day of week for which this entry defines the rates, where 0 stands for Sunday, 1 for Monday and so on until the digit 6 which stands for Saturday.
The rest of the line consists of one or more space separated fields which have the following syntax:
Start_hour and start_minutes define the begin of a time section and end_hour and end_minutes define the end. Charge_unit_length define the length of a charging unit in the previously defined time section. No spaces or tabs are allowed inside this field. The hour and minutes specifications MUST have exactly 2 digits, in case just one digit is needed, a leading 0 must be used.
defines, that between 2:00 PM and 6:00 PM the length of one charging unit lasts 90 seconds.
The default rates specification file for the isdnd ISDN daemon.
ra0 0 00.00-05.00:240 05.00-21.00:150 21.00-24.00:240
defines the unit lengths for a Sunday.
The rates subsystem for the isdnd(8) daemon to which isdnd.rates belongs was designed and written by Gary Jennejohn.
The isdnd(8) daemon and this manual page were written by Hellmuth Michaelis 〈firstname.lastname@example.org〉.
MidnightBSD 0.3 September 11, 1998 MidnightBSD 0.3