LOADER.CONF(5) MidnightBSD File Formats Manual LOADER.CONF(5)
loader.conf — system bootstrap configuration information
The file loader.conf contains descriptive information on bootstrapping the system. Through it you can specify the kernel to be booted, parameters to be passed to it, and additional modules to be loaded; and generally set all variables described in loader(8).
The file /boot/loader.rc must contain the following two lines for loader.conf to be automatically processed:
If no /boot/loader.rc exists at installworld time, one with the above lines will be installed.
Though loader.conf’s format was defined explicitly to resemble rc.conf(5), and can be sourced by sh(1), some settings are treated in a special fashion. Also, the behavior of some settings is defined by the setting’s suffix; the prefix identifies which module the setting controls.
The general parsing rules are:
Spaces and empty lines are ignored.
A # sign will mark the remainder of the line as a comment.
Only one setting can be present on each line.
All settings have the following format:
Unless it belongs to one of the classes of settings that receive special treatment, a setting will set the value of a loader(8) environment variable. The settings that receive special treatment are listed below. Settings beginning with "*" below define the modules to be loaded and may have any prefix; the prefix identifies a module. All such settings sharing a common prefix refer to the same module.
Immediately executes a loader(8) command. This type of setting cannot be processed by programs other than loader(8), so its use should be avoided. Multiple instances of it will be processed independently.
Defines additional configuration files to be processed right after the present file.
Name of the kernel to be loaded. If no kernel name is set, no additional modules will be loaded.
Flags to be passed to the kernel.
Provides a password to be required by check-password before execution is allowed to continue.
If set to ‘‘YES’’, module names will be displayed as they are loaded.
If set to ‘‘YES’’, that module will be loaded. If no name is defined (see below), the module’s name is taken to be the same as the prefix.
Defines the name of the module.
Defines the module’s type. If none is given, it defaults to a kld module.
Flags and parameters to be passed to the module.
Commands to be executed before the module is loaded. Use of this setting should be avoided.
Commands to be executed after the module is loaded. Use of this setting should be avoided.
Commands to be executed if the loading of a module fails. Except for the special value ‘‘abort’’, which aborts the bootstrap process, use of this setting should be avoided.
WARNING: developers should never use these suffixes for any kernel environment variables (tunables) or conflicts will result.
Most of loader.conf’s default settings can be ignored. The few of them which are important or useful are:
(‘‘NO’’) If set to ‘‘YES’’, a bitmap will be loaded to be displayed on screen while booting.
(‘‘/boot/splash.bmp’’) Name of the bitmap to be loaded. Any other name can be used.
(‘‘9600’’ or the value of the BOOT_COMCONSOLE_SPEED variable when loader(8) was compiled). Sets the speed of the serial console. If the previous boot loader stage specified that a serial console is in use then the default speed is determined from the current serial port speed setting.
(‘‘vidconsole’’) ‘‘comconsole’’ selects serial console, ‘‘vidconsole’’ selects the video console, and ‘‘nullconsole’’ selects a mute console (useful for systems with neither a video console nor a serial port).
(‘‘NO’’) If set to ‘‘YES’’, will load the splash screen module, making it possible to display a bmp image on the screen while booting.
(‘‘NO’’) If set to ‘‘YES’’, will load the splash screen module, making it possible to display a pcx image on the screen while booting.
(‘‘NO’’) If set to ‘‘YES’’, the vesa module will be loaded, enabling bitmaps above VGA resolution to be displayed.
If set to ‘‘YES’’, the beastie boot menu will be skipped.
Selects a desired logo in the beastie boot menu. Possible values are: ‘‘fbsdbw’’, ‘‘beastiebw’’, ‘‘beastie’’, and ‘‘none’’.
default settings -- do not change this file.
defines the commands used by loader to read and process loader.conf.
user defined settings.
machine-specific settings for sites with a common loader.conf.
contains the instructions to automatically process loader.conf.
boot(8), loader(8), loader.4th(8)
The file loader.conf first appeared in FreeBSD 3.2.
This manual page was written by Daniel C. Sobral 〈dcs@FreeBSD.org〉.
MidnightBSD 0.3 November 15, 2005 MidnightBSD 0.3