MAC_NONE(4) MidnightBSD Kernel Interfaces Manual MAC_NONE(4)
mac_none — null MAC policy module
To compile the null policy into your kernel, place the following lines in your kernel configuration file:
Alternately, to load the sample module at boot time, place the following line in your kernel configuration file:
and in loader.conf(5):
The mac_none policy module implements a sample MAC policy that has no effect on access control in the system. Unlike mac_stub(4), none of the MAC entry points are defined.
No labels are defined for mac_none.
mac(4), mac_biba(4), mac_bsdextended(4), mac_ifoff(4), mac_lomac(4), mac_mls(4), mac_partition(4), mac_portacl(4), mac_seeotheruids(4), mac_stub(4), mac_test(4), mac(9)
The mac_none policy module first appeared in FreeBSD 5.0 and was developed by the TrustedBSD Project.
This software was contributed to the FreeBSD Project by Network Associates Labs, the Security Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (‘‘CBOSS’’), as part of the DARPA CHATS research program.
See mac(9) concerning appropriateness for production use. The TrustedBSD MAC Framework is considered experimental in FreeBSD.
While the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
MidnightBSD 0.3 December 1, 2002 MidnightBSD 0.3