MD(4) MidnightBSD Kernel Interfaces Manual MD(4)
md — memory disk
The md driver provides support for four kinds of memory backed virtual disks:
Backing store is allocated using malloc(9). Only one malloc-bucket is used, which means that all md devices with malloc backing must share the malloc-per-bucket-quota. The exact size of this quota varies, in particular with the amount of RAM in the system. The exact value can be determined with vmstat(8).
A file loaded by loader(8) with type ‘md_image’ is used for backing store. For backwards compatibility the type ‘mfs_root’ is also recognized. If the kernel is created with option MD_ROOT the first preloaded image found will become the root file system.
A regular file is used as backing store. This allows for mounting ISO images without the tedious detour over actual physical media.
Backing store is allocated from swap space.
For more information, please see mdconfig(8).
disklabel(5), disklabel(8), fdisk(8), loader(8), mdconfig(8), mdmfs(8), newfs(8), vmstat(8)
The md driver first appeared in FreeBSD 4.0 as a cleaner replacement for the MFS functionality previously used in PicoBSD and in the FreeBSD installation process.
The md driver did a hostile takeover of the vn(4) driver in FreeBSD 5.0.
The md driver was written by Poul-Henning Kamp 〈phk@FreeBSD.org〉.
MidnightBSD 0.3 March 9, 2001 MidnightBSD 0.3