MFI(4) MidnightBSD Kernel Interfaces Manual MFI(4)
mfi — LSI MegaRAID SAS driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
This driver is for LSI’s next generation PCI Express SAS RAID controllers. Access to RAID arrays (logical disks) from this driver is provided via /dev/mfid? device nodes. A simple management interface is also provided on a per-controller basis via the /dev/mfi? device node.
The mfi name is derived from the phrase "MegaRAID Firmware Interface", which is substantially different than the old "MegaRAID" interface and thus requires a new driver. Older SCSI and SATA MegaRAID cards are supported by amr(4) and will not work with this driver.
The mfi driver supports the following hardware:
LSI MegaRAID SAS 8408E
LSI MegaRAID SAS 8480E
array/logical disk interface
The mfi driver first appeared in FreeBSD 7.0.
The mfi driver and this manual page were written by Scott Long 〈scottl@FreeBSD.org〉.
The driver does not support big-endian architectures at this time.
MidnightBSD 0.3 April 1, 2006 MidnightBSD 0.3