MODULI(5) MidnightBSD File Formats Manual MODULI(5)
moduli — system moduli file
The moduli file contains the system-wide Diffie-Hellman prime moduli for the photurisd(8) and sshd(8) programs.
Each line in this file contains the following fields: Time, Type, Tests, Tries, Size, Generator, and Modulus. The fields are separated by white space (tab or blank).
Specifies the system time that the line was appended to the file. The value 00000000000000 means unknown (historic).
Specifies the internal structure of the prime modulus.
unknown; often learned from peer during protocol operation, and saved for later analysis.
unstructured; a common large number.
safe (p = 2q + 1); meets basic structural requirements.
Sophie-Germaine (q = (p-1)/2); usually generated in the process of testing safe or strong primes.
strong; useful for RSA public key generation.
Tests (decimal) (bit field)
Specifies the methods used in checking for primality. Usually, more than one test is used.
not tested; often learned from peer during protocol operation, and saved for later analysis.
composite; failed one or more tests. In this case, the highest bit specifies the test that failed.
sieve; checked for division by a range of smaller primes.
Depends on the value of the highest valid Test bit, where the method specified is:
not tested (always zero).
sieve; number of primes sieved. Commonly on the order of 32,000,000.
Miller-Rabin; number of M-R iterations. Commonly on the order of 32 to 64.
Jacobi; unknown (always zero).
Elliptic Curve; unused (always zero).
Specifies the number of significant bits.
Generator (hex string)
Specifies the best generator for a Diffie-Hellman exchange. 0 = unknown or variable, 2, 3, 5, etc.
Modulus (hex string)
The prime modulus.
The file is searched for moduli that meet the appropriate Time, Size and Generator criteria. When more than one meet the criteria, the selection should be weighted toward newer moduli, without completely disqualifying older moduli.
MidnightBSD 0.3 July 28, 1997 MidnightBSD 0.3