NG_DEVICE(4) MidnightBSD Kernel Interfaces Manual NG_DEVICE(4)
ng_device — device netgraph node type
A device node is both a netgraph node and a system device interface. When a device node is created, a new device entry appears which is accessible via the regular file operators such as open(2), close(2), read(2), write(2), etc.
The first node is created as /dev/ngd0, all subsequent nodes /dev/ngd1, /dev/ngd2, etc.
A device node has a single hook with an arbitrary name. All data coming in over the hook will be presented to the device for read(2). All data coming in from the device entry by write(2) will be forwarded to the hook.
The device node supports one non-generic control message:
Returns device name corresponding to a node.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or upon hook disconnection. The associated device entry is removed and becomes available for use by future device nodes.
The device node type was first implemented in FreeBSD 5.0.
Gleb Smirnoff 〈glebius@FreeBSD.org〉
MidnightBSD 0.3 October 19, 2004 MidnightBSD 0.3