NSMB.CONF(5) MidnightBSD File Formats Manual NSMB.CONF(5)
nsmb.conf — configuration file for SMB requests
The nsmb.conf file contains information about the computers, users, and shares or mount points for the SMB network protocol.
The configuration hierarchy is made up of several sections, each section containing a few or several lines of parameters and their assigned values. Each of these sections must begin with a section name enclosed within square brackets, similar to:
The end of each section is marked by either the start of a new section, or by the abrupt ending of the file, commonly referred to as the EOF. Each section may contain zero or more parameters such as:
where key represents a parameter name, and value would be the parameter’s assigned value.
The SMB library uses the following information for section names:
Possible keywords may include:
A B C D
addr - + - - IP or IPX address of SMB server
charsets - + + + local:remote charset pair
nbns + + - - address of NetBIOS name server (WINS)
nbscope + + - - NetBIOS scope
nbtimeout + + - - timeout for NetBIOS name servers
password - - + + plain text password used to access the given share
retry_count + + - - number of retries before connection is marked as broken
timeout + + - - SMB request timeout
workgroup + + + + workgroup name
The default remote mount-point configuration file.
What follows is a sample configuration file which may, or may not match your environment:
# Configuration file
# The ’FSERVER’ is an NT server.
All lines which begin with the ‘#’ character are comments and will not be parsed. The ‘‘default’’ section describes the default workgroup or domain, in this case ‘‘SALES’’. The next section depicted here as ‘‘FSERVER’’, defines a server section and then assigns it a charset which is only required when Cyrillic characters are not used. The hostname value, ‘‘fserv.example.com’’, is also assigned in this section.
At the time of this writing, the IPX protocol remains unsupported. Future FreeBSD releases are expected to support this.
This manual page was written by Sergey Osokin 〈osa@FreeBSD.org〉 and Tom Rhodes 〈trhodes@FreeBSD.org〉.
MidnightBSD 0.3 June 30, 2003 MidnightBSD 0.3