NVE(4) MidnightBSD Kernel Interfaces Manual NVE(4)
nve — NVIDIA nForce MCP Networking Adapter device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The nve driver provides support for the NVIDIA nForce MCP and nForce2 MCP2 networking adapter that is embedded in the southbridge of most nForce and nForce2 motherboards.
This driver is a reimplementation of the NVIDIA supported Linux nvnet driver and uses the same closed source API library to access the underlying hardware. There is currently no programming documentation available for this device, and therefore little is known about the internal architecture of the MAC engine itself.
The nve driver supports the following media types:
Enable autoselection of the media type and options.
Set 10Mbps operation.
Set 100Mbps (Fast Ethernet) operation.
The nve driver supports the following media options:
Set full duplex operation.
For more information on configuring this device, see ifconfig(8).
The nve driver supports the NVIDIA MCP onboard adapters of mainboards with the following chipsets:
nve%d: couldn’t map memory A fatal initialization error has occurred.
nve%d: couldn’t map interrupt A fatal initialization error has occurred.
nve%d: failed to allocate memory There are not enough mbufs available for allocation.
nve%d: device timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
The nve driver first appeared in FreeBSD 6.0.
The nve driver was written by Quinton Dolan 〈firstname.lastname@example.org〉 and David E. O’Brien 〈obrien@FreeBSD.org〉.
MidnightBSD 0.3 August 9, 2005 MidnightBSD 0.3