SBSH(4) MidnightBSD Kernel Interfaces Manual SBSH(4)
sbsh — Granch SBNI16 SHDSL modem device driver
The sbsh driver provides support for an internal PCI modem SBNI16-SHDSL. A device is introduced to the OS as a common Ethernet-like network card which must be configured with ifconfig(8) (all standard network interface parameters could be set). Modem-specific parameters (master/slave mode, line rate, etc.) must be set with the sb16config utility before interface activation.
The sources for the driver reside in:
sbsh%d: couldn’t map
sbsh%d: couldn’t map interrupt
sbsh%d: couldn’t set up irq A fatal initialization error has occurred.
sbsh%d: unable to load firmware A fatal error has occurred while sb16config was running.
sbsh%d: firmware wasn’t loaded ‘‘ifconfig ... up’’ has failed because device has not been configured with sb16config.
sbsh%d: interrupt posted but not delivered Probably, a hardware error or incompatibility.
sbsh%d: unable to get
sbsh%d: unable to get mbuf cluster The driver failed to allocate a memory buffer.
arp(4), netintro(4), ifconfig(8)
The sbsh device driver first appeared in FreeBSD 4.9.
The sbsh driver was written by Denis I. Timofeev 〈email@example.com〉.
MidnightBSD 0.3 April 11, 2003 MidnightBSD 0.3