SCHED_ULE(4) MidnightBSD Kernel Interfaces Manual SCHED_ULE(4)
sched_ule — ULE Scheduler
The sched_ule scheduler is an experimental scheduler that provides a number of advanced scheduler features not present in sched_4bsd(4), the default system scheduler. These features address SMP and interactivity and include:
Thread CPU affinity.
CPU topology awareness, including for hyper-threading.
Per-CPU run queues.
Interactivity heuristics that detect interactive applications and schedules them preferentially under high load.
The following sysctls are relevant to the operation of sched_ule:
This read-only sysctl reports the name of the active scheduler.
The sched_ule scheduler is disabled by default as it is experimental. See the BUGS section for more information.
The sched_ule scheduler first appeared in FreeBSD 5.1.
Jeff Roberson 〈jeff@FreeBSD.org〉
As an experimental scheduler, sched_ule is not enabled by default due to a number of known issues, including weak performance with several known workloads, and reports of instability. Deployment of sched_ule in production environments should be done cautiously.
MidnightBSD 0.3 April 7, 2005 MidnightBSD 0.3