SND_SBC(4) MidnightBSD Kernel Interfaces Manual SND_SBC(4)
snd_sbc — Creative Sound Blaster ISA and compatible bridge device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
Non-PnP cards require the following lines in device.hints(5):
The snd_sbc bridge driver allows the generic audio drivers including sound(4) to attach to Creative Sound Blaster ISA compatible audio cards.
The value of flags specifies the secondary DMA channel. If the secondary DMA channel is C, set the flags to (C | 0x10). For a sound card without the secondary DMA channel, the flags should be set to zero.
The snd_sbc driver supports the following sound cards:
Avance Asound 110
Avance Logic ALS100+
Avance Logic ALS120
Creative AWE64 Gold
sb_dspwr(XX) timed out. A command to the DSP has timed out. Check the I/O port configuration.
bad irq XX (5/7/9/10 valid) The IRQ given to the driver is not valid.
The snd_sbc device driver first appeared in FreeBSD 4.0.
Seigo Tanimura 〈firstname.lastname@example.org〉
MidnightBSD 0.3 December 15, 2005 MidnightBSD 0.3