SND_VIA8233(4) MidnightBSD Kernel Interfaces Manual SND_VIA8233(4)
snd_via8233 — VIA Technologies VT8233 bridge device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The snd_via8233 bridge driver allows the generic audio driver, sound(4), to attach to the VIA VT8233 audio devices. These audio chipsets are integrated in the southbridge on many VIA based motherboards.
The snd_via8233 driver supports the following audio chipsets:
The snd_via8233 device driver first appeared in FreeBSD 4.7.
This manual page was written by Joel Dahl 〈joel@FreeBSD.org〉.
The snd_via8233 driver does not support S/PDIF. There is partial support in the code, so implementing it should be fairly easy if the right hardware is available.
MidnightBSD 0.3 December 1, 2005 MidnightBSD 0.3