SNP(4) MidnightBSD Kernel Interfaces Manual SNP(4)
snp — tty snoop interface
ioctl(fd, SNPSTTY, &dev);
ioctl(fd, SNPGTTY, &dev);
ioctl(fd, FIONREAD, &result);
/dev/snp? are snoop devices which allow users to attach to any tty and watch activities on it. The kernel must be compiled with device snp, or the snp module must be loaded, for these devices to be available.
To associate a given snp device with a tty to be observed, open the snp device and a tty device, and then issue the SNPSTTY ioctl on snp device. The argument passed to the ioctl(2) is the address of a variable of type int, holding the file descriptor of a tty device. To detach the snp device from a tty use a pointer to a value of −1.
The SNPGTTY ioctl returns information about the current tty attached to the open snp device.
The FIONREAD ioctl returns a positive value equal to the number of characters in a read buffer. Special values defined are:
device overflow occurred, device detached.
tty not attached.
snp device has been detached by user or tty device has been closed and detached.
pty(4), sio(4), kldload(8), watch(8)
The snp device first appeared in FreeBSD 2.1.
Ugen J.S. Antsilevich 〈ugen@NetVision.net.il〉
Caveat emptor! This manual page is horribly stale and wildly inaccurate in some places.
While in line mode, user input cannot be seen. No signals may be sent to the observed tty.
MidnightBSD 0.3 September 18, 2005 MidnightBSD 0.3