STG(4) MidnightBSD Kernel Interfaces Manual STG(4)
stg — driver for Future Domain based SCSI controllers
In /boot/device.hints (for ISA controllers):
The stg driver provides support for ISA, PCCARD and PCI controllers based on Future Domain SCSI controller chips including the TMC-16C30, 16C50 and 32C60.
Controllers supported by the stg driver include:
Future Domain SCSI2GO
Future Domain TMC-18XX/3260
IBM SCSI PCMCIA Card
ICM PSC-2401 SCSI
RATOC REX-5536, REX-5536AM, REX-5536M, REX-9836A
Note that the Adaptec 2920C is supported by the ahc(4) driver.
ahc(4), cd(4), ch(4), da(4), intro(4), sa(4), scsi(4)
The stg device driver has been developed for NetBSD/pc98 and ported for FreeBSD. It first appeared in FreeBSD 2.2 with PAO and merged in FreeBSD 4.2.
The stg driver was written by Naofumi HONDA.
MidnightBSD 0.3 August 8, 2004 MidnightBSD 0.3