TX(4) MidnightBSD Kernel Interfaces Manual TX(4)
tx — SMC 83c17x Fast Ethernet device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The tx driver provides support for the Ethernet adapters based on the SMC 83c17x (EPIC) chips. These are mostly SMC 9432 series cards.
The tx driver supports the following media types (depending on card’s capabilities):
Enable autonegotiation (default).
Set 100Mbps (Fast Ethernet) fiber optic operation.
Set 100Mbps (Fast Ethernet) twisted pair operation.
Set 10Mbps on 10baseT port.
Set 10Mbps on 10base2 port.
The tx driver supports the following media options:
Set full-duplex operation.
The tx driver supports oversized Ethernet packets (up to 1600 bytes). Refer to the ifconfig(8) man page on setting the interface’s MTU.
The old ‘‘ifconfig tx0 linkN’’ method of configuration is not supported.
VLAN (IEEE 802.1Q)
The tx driver supports the VLAN operation (using vlan(4) interfaces) without decreasing the MTU on the vlan(4) interfaces.
tx%d: device timeout %d packets The device stops responding. Device and driver reset follows this error.
tx%d: PCI fatal error occurred (%s) One of following errors occurred: PCI Target Abort, PCI Master Abort, Data Parity Error or Address Parity Error. Device and driver reset follows this error.
tx%d: cannot allocate mbuf header/cluster Cannot allocate memory for received packet. Packet thrown away.
tx%d: can’t stop %s DMA While resetting, the driver failed to stop the device correctly.
arp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
The auto-negotiation does not work very well.
MidnightBSD 0.3 July 16, 2005 MidnightBSD 0.3