UFM(4) MidnightBSD Kernel Interfaces Manual UFM(4)
ufm — USB driver for Cypress Semiconductor FM Radio
The ufm driver provides support for the D-Link/GEMTEK FM tuner. The USB interface chip is the common Cypress 63001, and the tuner is a Philips TEA5757 radio chip that uses a serial interface to set the tuner parameters. This design is used in the D-Link DSB-R100 USB Radio.
The ufm device must be configured in the kernel, along with usb(4) and one of the uhci(4) or ohci(4) controllers.
Subsequently, the /dev/ufm0 device can be used by userland applications.
blocking device node
ohci(4), uhci(4), usb(4)
The ufm driver was written by M. Warner Losh 〈imp@FreeBSD.org〉 for FreeBSD.
MidnightBSD 0.3 November 7, 2003 MidnightBSD 0.3