UHIDEV(4) MidnightBSD Kernel Interfaces Manual UHIDEV(4)
uhidev — USB Human Interface Device support
The uhidev driver handles all Human Interface Devices. Each HID device can have several components, e.g., a keyboard and a mouse. These components use different report identifiers (a byte) to distinguish which one data is coming from. The uhidev driver has other drivers attached that handle particular kinds of devices and uhidev only dispatches data to them based on the report ID.
uhid(4), ukbd(4), ums(4), usb(4)
The uhidev driver appeared in NetBSD 1.6. This manual page was adopted from NetBSD by Tom Rhodes 〈trhodes@FreeBSD.org〉 in April 2002.
MidnightBSD 0.3 December 27, 2001 MidnightBSD 0.3