UMCT(4) MidnightBSD Kernel Interfaces Manual UMCT(4)
umct — Magic Control Technology USB-RS232 converter driver
The umct driver provides support for USB to RS-232 converters based on the Magic Control Technology USB-232 design. These devices support most of the standard RS-232 features including baud rates ranging from 300 to 115200 bits per second. However, neither hardware nor software flow control seems to be supported.
Access to devices under this driver is via the ucom(4) framework and device nodes.
The umct driver supports the following adapters:
D-Link DU-H3SP USB BAY Hub
Magic Control Technology USB-232
tty(4), ucom(4), usb(4)
The umct driver appeared in FreeBSD 5.2. It is loosely based on the ubsa(4) driver by Alexander Kabaev 〈kan@FreeBSD.org〉 with documentation from Wolfgang Grandeggar 〈firstname.lastname@example.org〉.
The umct driver was written by Scott Long 〈scottl@FreeBSD.org〉.
MidnightBSD 0.3 February 29, 2004 MidnightBSD 0.3