URIO(4) MidnightBSD Kernel Interfaces Manual URIO(4)
urio — USB driver for the Rio MP3 players
The urio driver provides support for Rio MP3 players from Diamond MultiMedia which attaches to the USB port. The urio device must be configured in the kernel, along with usb and one of the uhci or ohci controllers.
Subsequently, the /dev/urio0 device can be used by the Rio userland applications.
The following devices are supported by the urio driver:
Diamond MultiMedia Rio 500
Diamond MultiMedia Rio 600
Diamond MultiMedia Rio 800
blocking device node
The following line in the kernel configuration file adds the urio driver to the kernel:
To download a song over the USB connection into the Rio using the rio_add_song(1) utility (see the SEE ALSO section):
ohci(4), uhci(4), usb(4)
The Rio 500 SourceForge Project Web Page
The Rio500 tools from SourceForge are the actual userland tools used to download, format or rename songs on players. When compiling these tools, the following pre-build configuration command will ensure that rio_usb.h is available in the include path and that the device used is /dev/urio0:
CFLAGS="-I/usr/include/dev/usb" ./configure \
The urio driver was written by Iwasa Kazmi 〈firstname.lastname@example.org〉 for FreeBSD.
This manual page was written by Dirk-Willem van Gulik 〈email@example.com〉.
MidnightBSD 0.3 September 26, 2004 MidnightBSD 0.3