VGE(4) MidnightBSD Kernel Interfaces Manual VGE(4)
vge — VIA Networking Technologies VT6122 PCI Gigabit Ethernet adapter driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The vge driver provides support for various NICs and embedded Ethernet interfaces based on the VIA Networking Technologies VT6122 Gigabit Ethernet controller chips.
The VT6122 is a 33/66Mhz 64-bit PCI device which combines a tri-speed MAC with an integrated 10/100/1000 copper PHY. (Some older cards use an external PHY.) The MAC supports TCP/IP hardware checksums (IPv4 only), TCP large send, VLAN tag insertion and stripping, as well as VLAN filtering, a 64-entry CAM filter and a 64-entry VLAN filter, 64-bit multicast hash filter, 4 separate transmit DMA queues, flow control and jumbo frames up to 16K in size. The VT6122 has a 16K receive FIFO and 48K transmit FIFO.
The vge driver takes advantage of the VT6122’s checksum offload and VLAN tagging features, as well as the jumbo frame and CAM filter support. The CAM filter is used for multicast address filtering to provide 64 perfect multicast address filter support. If it is necessary for the interface to join more than 64 multicast groups, the driver will switch over to using the hash filter.
The jumbo frame support can be enabled by setting the interface MTU to any value larger than the default of 1500 bytes, up to a maximum of 9000 bytes. The receive and transmit checksum offload support can be toggled on and off using the ifconfig(8) utility.
The vge driver supports the following media types:
Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5).
Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
Set 100Mbps (Fast Ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
Set 1000baseTX operation over twisted pair. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
The vge driver supports the following media options:
Force full duplex operation.
Force half duplex operation.
The vge driver also supports one special link option for 1000baseTX cards:
With 1000baseTX cards, establishing a link between two ports requires that one port be configured as a master and the other a slave. With autonegotiation, the master/slave settings will be chosen automatically. However when manually selecting the link state, it is necessary to force one side of the link to be a master and the other a slave. The vge driver configures the ports as slaves by default. Setting the link0 flag with ifconfig(8) will set a port as a master instead.
For more information on configuring this device, see ifconfig(8).
The vge driver supports VIA Networking VT3119 and VT6122 based Gigabit Ethernet adapters including:
VIA Networking LAN-on-motherboard Gigabit Ethernet
ZyXEL GN650-T 64-bit PCI Gigabit Ethernet NIC (ZX1701)
ZyXEL GN670-T 32-bit PCI Gigabit Ethernet NIC (ZX1702)
vge%d: couldn’t map memory A fatal initialization error has occurred.
vge%d: couldn’t map ports A fatal initialization error has occurred.
vge%d: couldn’t map interrupt A fatal initialization error has occurred.
vge%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot.
vge%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
The vge device driver first appeared in FreeBSD 5.3.
The vge driver was written by Bill Paul 〈email@example.com〉.
MidnightBSD 0.3 July 16, 2005 MidnightBSD 0.3