WATCHDOG(4) MidnightBSD Kernel Interfaces Manual WATCHDOG(4)
watchdog — hardware and software watchdog
The watchdog facility is used for controlling hardware and software watchdogs.
The interface is through a device named "/dev/" _PATH_WATCHDOG which responds to a single ioctl(2) call, WDIOCPATPAT.
The call takes a single argument which represents a timeout value specified as an integer power of two nanoseconds.
The WD_ACTIVE flag signals that the watchdog will be kept from timing out from userland, for instance by the watchdogd(8) daemon.
To disable the watchdogs, an argument of zero should be used.
The ioctl(2) call will return success if just one of the available watchdog(9) implementations support the request. If the call fails, for instance if none of watchdog(9) implementations support the timeout length, all watchdogs are disabled and must be explicitly re-enabled.
u_int u = WD_ACTIVE | WD_TO_8SEC;
int fd = open("/dev/" _PATH_WATCHDOG, O_RDWR);
ioctl(fd, WDIOCPATPAT, &u);
The watchdog code first appeared in FreeBSD 5.1.
The watchdog facility was written by Poul-Henning Kamp 〈phk@FreeBSD.org〉. The software watchdog code and this manual page were written by Sean Kelly 〈smkelly@FreeBSD.org〉. Some contributions were made by Jeff Roberson 〈jeff@FreeBSD.org〉.
MidnightBSD 0.3 June 25, 2003 MidnightBSD 0.3