WLAN_CCMP(4) MidnightBSD Kernel Interfaces Manual WLAN_CCMP(4)
wlan_ccmp — AES-CCMP crypto support for 802.11 devices
The wlan_ccmp module handles the AES-CCMP cryptographic requirements of the WPA and 802.11i protocols. It does encapsulation and decapsulation of CCMP-encoded 802.11 frames and optionally calculates the AES-CCMP cipher. The wlan_ccmp module is an 802.11 cryptographic plugin module for use by the wlan(4) module. This module is automatically loaded if an AES-CCMP key is configured; typically by a WPA supplicant program such as wpa_supplicant, or a WPA authenticator program such as hostapd. Should the underlying network device not be capable of doing the AES-CCMP calculations in hardware, the wlan_ccmp module will do the work.
wlan(4), wlan_tkip(4), wlan_wep(4)
More information can be found in the IEEE 802.11, WPA, and 802.11i Standards.
The wlan_ccmp driver first appeared in FreeBSD 6.0.
MidnightBSD 0.3 December 7, 2004 MidnightBSD 0.3