WLAN_XAUTH(4) MidnightBSD Kernel Interfaces Manual WLAN_XAUTH(4)
wlan_xauth — External authenticator support for 802.11 devices
The wlan_xauth module implements an authenticator plugin that is intended for use with user-mode authentication implementations such as hostapd. It hooks into the 802.11 layer and does nothing. As a result, 802.11 stations that associate are not authorized to send or receive frames until they are authorized by an external agent; typically using a protocol such as WPA, 802.1x, or 802.11i. The wlan_xauth module is an 802.11 authenticator plugin module for use by the wlan(4) module. This module is automatically loaded if an application configures an 802.11 device for operation as an AP with WPA or 802.1x authentication.
More information can be found in the IEEE 802.11, WPA, and 802.11i Standards.
The wlan_xauth driver first appeared in FreeBSD 6.0.
MidnightBSD 0.3 December 7, 2004 MidnightBSD 0.3