WORM(4) MidnightBSD Kernel Interfaces Manual WORM(4)
worm — write-once (CD-R) disk driver
The worm driver was provided under FreeBSD releases prior to FreeBSD 3.0.
The FreeBSD SCSI layer was replaced for FreeBSD 3.0 by a CAM-compliant SCSI layer. The new SCSI layer does not include a worm driver, and is not likely to include one in the future. Future in-kernel support for CD-R/CD-RW/DVD drives will likely be implemented through the cd(4) driver. Users who wish to write CDs on a WORM, CD-R, or CD-RW drive should use cdrtools, which is in the FreeBSD ports collection.
The cd(4) driver provides read-only access to CD, CD-R, and CD-RW drives, as well as WORM drives that support the CDROM command set. Therefore, users wishing to mount CDs in a WORM drive should use the cd(4) driver instead.
close(2), ioctl(2), open(2), write(2), cd(4), pass(4), xpt(4)
The worm driver appeared in FreeBSD 2.1, and disappeared in FreeBSD 3.0 with the advent of the CAM SCSI layer.
The first skeleton for a worm driver has been written by Peter Dufault in May, 1995. The driver has then been improved and made actually usable at all by Jörg Wunsch in January, 1996.
MidnightBSD 0.3 October 15, 1998 MidnightBSD 0.3