ZERO(4) MidnightBSD Kernel Interfaces Manual ZERO(4)
zero — the zero device
The zero device accepts and reads data as any ordinary (and willing) file, but throws away any data written to it, and returns an endless supply of null bytes when read.
A zero device appeared in 4.4BSD.
MidnightBSD 0.3 April 7, 1996 MidnightBSD 0.3