MidnightBSD Magus

x11-toolkits/pangomm

C++ wrapper for Pango

Version Run OSVersion Arch License Restricted Status
2.14.1 150 0.2.1 amd64 gpl2 0 fail

Events

Machine Type Time Message
ds9 info 2009-06-05 01:37:06 Test Started
ds9 fail 2009-06-05 01:38:23 make configure returned non-zero: 1
ds9 fail 2009-06-05 01:38:23 Test complete.

Log

===>   pangomm-2.14.1 depends on executable: gm4 - not found
===>    Verifying magus-install-depend for gm4 in /usr/mports/devel/m4
===>  Installing /magus/packages/All/m4-1.4.12.tbz
===>  Done.
===>   Returning to build of pangomm-2.14.1
===>   pangomm-2.14.1 depends on executable: gmake - not found
===>    Verifying magus-install-depend for gmake in /usr/mports/devel/gmake
===>  Installing /magus/packages/All/gmake-3.81_2.tbz
===>   gmake-3.81_2 depends on shared library: intlldconfig: Cannot open "/var/run/ld-elf.so.hints": No such file or directory
 - not found
===>    Verifying magus-install-depend for intl in /usr/mports/devel/gettext
===>  Installing /magus/packages/All/gettext-0.17_1.tbz
===>   gettext-0.17_1 depends on shared library: iconv.3ldconfig: Cannot open "/var/run/ld-elf.so.hints": No such file or directory
 - not found
===>    Verifying magus-install-depend for iconv.3 in /usr/mports/converters/libiconv
===>  Installing /magus/packages/All/libiconv-1.11,1.tbz
===>  Done.
===>   Returning to build of gettext-0.17_1
===>  Done.
===>   Returning to build of gmake-3.81_2
===>  Done.
===>   Returning to build of pangomm-2.14.1
===>   pangomm-2.14.1 depends on executable: pkg-config - not found
===>    Verifying magus-install-depend for pkg-config in /usr/mports/devel/pkg-config
===>  Installing /magus/packages/All/pkg-config-0.23_1.tbz
===>  Done.
===>   Returning to build of pangomm-2.14.1
===>   pangomm-2.14.1 depends on shared library: glibmm-2.4.1 - not found
===>    Verifying magus-install-depend for glibmm-2.4.1 in /usr/mports/devel/glibmm
===>  Installing /magus/packages/All/glibmm-2.18.1,1.tbz
===>   glibmm-2.18.1,1 depends on file: /usr/local/bin/perl5.10.0 - not found
===>    Verifying magus-install-depend for /usr/local/bin/perl5.10.0 in /usr/mports/lang/perl5.10
===>  Installing /magus/packages/All/perl-5.10.0_2.tbz
Removing stale symlinks from /usr/bin...
    Removing /usr/bin/perl
    Skipping /usr/bin/perl5.10.0
    Removing /usr/bin/perl5.8.8 installed by an older perl port
Done.
Creating symlnks to /usr/bin
	Linking /usr/local/bin/perl to /usr/bin/perl
	Linking /usr/local/bin/perl5.10.0 to /usr/bin/perl5.10.0
Done.
Cleaning up /etc/make.conf... Done.
Cleaning up /etc/manpath.config... Done.
Spamming /etc/manpath.config... Done.
===>  Done.
===>   Returning to build of glibmm-2.18.1,1
===>   glibmm-2.18.1,1 depends on executable in : pkg-config - found
===>   glibmm-2.18.1,1 depends on file: /usr/local/lib/gio/modules/libgiofam.so - not found
===>    Verifying magus-install-depend for /usr/local/lib/gio/modules/libgiofam.so in /usr/mports/devel/gio-fam-backend
===>  Installing /magus/packages/All/gio-fam-backend-2.20.1.tbz
===>   gio-fam-backend-2.20.1 depends on executable in : pkg-config - found
===>   gio-fam-backend-2.20.1 depends on shared library: glib-2.0.0 - not found
===>    Verifying magus-install-depend for glib-2.0.0 in /usr/mports/devel/glib20
===>  Installing /magus/packages/All/glib20-2.20.1_1.tbz
===>   glib20-2.20.1_1 depends on file: /usr/local/bin/perl5.10.0 - found
===>   glib20-2.20.1_1 depends on file: /usr/local/bin/python2.5 - not found
===>    Verifying magus-install-depend for /usr/local/bin/python2.5 in /usr/mports/lang/python25
===>  Installing /magus/packages/All/python25-2.5.4_2.tbz

Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3		databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.

===>  Done.
===>   Returning to build of glib20-2.20.1_1
===>   glib20-2.20.1_1 depends on executable in : pkg-config - found
===>   glib20-2.20.1_1 depends on shared library: pcre.0 - not found
===>    Verifying magus-install-depend for pcre.0 in /usr/mports/devel/pcre
===>  Installing /magus/packages/All/pcre-7.8.tbz
===>  Done.
===>   Returning to build of glib20-2.20.1_1
===>   glib20-2.20.1_1 depends on shared library: intl - found
===>  Done.
===>   Returning to build of gio-fam-backend-2.20.1
===>   gio-fam-backend-2.20.1 depends on shared library: fam.0 - not found
===>    Verifying magus-install-depend for fam.0 in /usr/mports/devel/gamin
===>  Installing /magus/packages/All/gamin-0.1.10.tbz
===>   gamin-0.1.10 depends on executable in : pkg-config - found
===>   gamin-0.1.10 depends on shared library: glib-2.0.0 - found

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

For a typical desktop, add the following line to /boot/loader.conf, then
reboot the system:

    kern.maxfiles="25000"

===>  Done.
===>   Returning to build of gio-fam-backend-2.20.1
===>  Done.
===>   Returning to build of glibmm-2.18.1,1
===>   glibmm-2.18.1,1 depends on shared library: sigc-2.0.0 - not found
===>    Verifying magus-install-depend for sigc-2.0.0 in /usr/mports/devel/libsigc++20
===>  Installing /magus/packages/All/libsigc++-2.2.2.tbz
===>   libsigc++-2.2.2 depends on executable in : pkg-config - found
===>  Done.
===>   Returning to build of glibmm-2.18.1,1
===>   glibmm-2.18.1,1 depends on shared library: glib-2.0.0 - found
===>  Done.
===>   Returning to build of pangomm-2.14.1
Error: shared library "glibmm-2.4.1" does not exist
*** Error code 1

Stop in /usr/mports/x11-toolkits/pangomm.