[Midnightbsd-cvs] src: UPDATING: Explain the pcc, elf, ssh-vulnkey + blacklists changes.

laffer1 at midnightbsd.org laffer1 at midnightbsd.org
Fri May 16 18:38:32 EDT 2008

Log Message:
Explain the pcc, elf, ssh-vulnkey + blacklists changes.

Modified Files:
        UPDATING (r1.36 -> r1.37)

-------------- next part --------------
RCS file: /home/cvs/src/UPDATING,v
retrieving revision 1.36
retrieving revision 1.37
diff -L UPDATING -L UPDATING -u -r1.36 -r1.37
@@ -3,6 +3,24 @@
 Items affecting the mports and packages system can be found in
+	ssh-vulnkey allows you to look for vulnerable ssh keys that
+	were generated on Debian and Ubuntu hosts over the last
+	few years.  sshd can block offending keys with a configuration
+	option.
+	The elf note on binaries is now set to MidnightBSD.
+	Fixed a number of problems with pcc.  It is not yet connected
+	to the build, but usable on i386 hosts.  You may use it 
+	by make; make install in /usr/src/usr.bin/pcc.  It will
+	install in /usr/local as some of the files conflict with
+	GCC versions. __MidnightBSD__ is defined in PCC as well.
+	System headers were fixed to allow pcc to compile many binaries
+	on MidnightBSD.  bin/cp will work now for instance.
 	__MidnightBSD__ is now defined via gcc.  This can be tested
 	to determine we're running on MidnightBSD in the preprocessor.

More information about the Midnightbsd-cvs mailing list